You are here

What are the software and hardware requirements of the Beyond Level 4 course?

FAQ Question: 

What are the software and hardware requirements of the Beyond Level 4 course?

FAQ Answer: 

These are the minimum system requirements:

  • Browser—Internet Explorer 7, Mozilla Firefox 3, Google Chrome 9, Apple Safari 5 or the latest version
  • Plug ins—Adobe Flash Player 10.1 or the latest version
  • Internet connection—1000 Kbps or higher (Our diagnostic tool will show you your internet connection speed. If the internet bandwidth is too low the program will be slow.)
  • Network availability—ports 80 and 1935
  • Peripherals—speakers/headphones, microphone.

Note: Beyond Level 4 will not operate on any device that does not support Adobe Flash Player.  For example, any device running iOS (iPhone or iPad) and Android v11.1 or higher.